Avamar backup fails after Virtual Machine restore

Posted: November 3, 2010 in AVAMAR, Tips and Tricks, VMware

Here’s the scenario,

  1. Using the Avamar management console, Add a Virtual Machine to the “Default Virtual Machine Group”
  2. Perform a Backup of the Virtual Machine
  3. Delete Virtual Machine using VI Client
  4. Perform a Virtual Machine Recovery back into Virtual Infrastructure
  5. Power Virtual Machine On
  6. Perform a Backup of the recovered Virtual Machine

I manually initiated a backup and saw the error shown below (A scheduled backup resulted in the error “NO VM“)

Because my NFS file systems are replicated I decided to perform a recovery back to a dedicated non replicated NFS datastore. At power on Virtual Center detects the Virtual Machine configuration file has moved and prompts with the following

This virtual machine might have been moved or copied.
In order to configure certain management and networking features, VMware ESX needs to know if this virtual machine was moved or copied.

If you don’t know, answer “I copied it”.
  • Cancel
  • I moved it
  • I copied it

I wasnt able to find anything on PowerLink about this, but I believe this is the root cause of the problem, Im always moving, copying and recovering Virtual Machines in the LAB and I’ve become accustom to selecting “I copied it” which generates a new UUID and before now have never had any problems.

I suspect when you add the Virtual Machine to Avamar it uses the UUID to track the VM as its common for VM’s to be renamed in vCenter. What I should have done is select “I Moved It” which results in the UUID being kept.

What I did to get around this was retire the Virtual Machine (choosing to keep the backup data based on retention) and then re-add the Virtual Machine again.

Backups were now successful.

I still need to do some more testing to confirm my suspicions around this being UUID related, but I would like to think that if this was the case, future versions of Avamar would let you update the configuration for situations where the Virtual Machine name stays the same but UUID changes.

I’ll update this post once I’ve confirmed.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s